Basic Interaction with

HyperMesh Desktop

Exercise 1a - Interacting With HyperMesh Desktop

This exercise will cover many of the basic concepts that are central to many of
the features in HyperMesh Desktop. By the end of this exercise you should be
familiar with the basic features of the HyperMesh Desktop software.

Step 1: Set the User Profile and retrieve the model file, 01a-GUl.hm

1. From the menu bar, select Preferences > User Profiles or select :;
the icon.
2. Select the OptiStruct user profile.
3. Click OK.
4. Select File > Open > Model from the menu bar or select the hadl icon.
5. Select the file 01a-GUTI . hm.
6. Click Open.
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Step 2: Rotate, Pan and Zoom the model
1. Hold down the Ctrl key

2. Click the Left Mouse button. (Note the small square in the center of the screen
indicating the rotational center).
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3. While holding both the Ctrl Key and Left Mouse Button, drag your mouse
around to rotate the model.

4. While holding the Ctrl Key, click Left Mouse Button near a node (Note the
small square moves to the node selected and becomes the new center of
rotation). Continue to rotate the model.

5. While holding the Ctrl Key and the Right Mouse Button, drag your mouse
around to pan the model.

6. While holding the Ctrl Key, click the Center Mouse Button (or clickable scroll
wheel) and draw a circle around a portion of the screen.

L

8. While holding the Ctrl Key, rotate the scroll wheel forward to Zoom Out and
backward to Zoom In.

9. While holding the Ctrl Key, click the middle mouse button/scroll wheel to “fit”
the model to the screen.
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Step 3: Use the Model Browser to control visualization

1. Press F on the keyboard to “fit” the model to the screen. If it does not work,
click in the graphics window and then press F.

2. Make sure the Model Browser tab > Model View icon 4 is active.
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3. Expand the Component category by clicking the + close to it. This will list all
of the components in the model.

4. Using the Geometry W and Elements | k2 Icons, turn on and off
components.

=g Component (25)

@ B Support GEOM-3D 1
@ B cyl3-GEOM-1D 8
@ B piston3-GEOM-1D 9
@ B cy12-GEOM-1D B
@ B piston2-GEOM-1D 7
@ B cy11-GEOM-2D 4
@ M piston1-GEOM-1D 5
@ B supp_cyl_pin-GEOM-3D 20
@ B supp_pin-GEOM-3D 21
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ﬂ B pin3-GEOM-3D 23
@ B pin1-GEOM-3D 24
@ B top_p-GEOM-3D 25
@ B cyl1_p-GEOM-3D 26
@ B bucket_p-GEOM-3D 27
@ B pin2-GEOM-3D 28
@ B bottom_p-GEOM-3D 29
@ B middle_p-GEOM-3D 30
@ B Scuaufel-GEOM-2D 14
m B b_t_link-GEOM-2D 10
ﬂ B f_t_link-GEOM-2D 1
@ B b_c_link-GEOM-2D 12
@ B f_c_link-GEOM-2D 13
o link1-GEOM-2D 2
@ B link2-GEOM-2D 3

Using the Show/Hide Button |+/= | turn off and on components in the graphics

window. Right click to hide a component and left click in the area of a hidden
component to see a ghost image of the hidden component. Releasing the button
reveals the component.
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Using the Isolate Button , left click on a component in the graphics
window to isolate it (turn off all other components) and right click on a hidden
component to see a ghost image of the hidden component. Releasing the
button isolates the selected component.
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Use the global controls to turn on, off and reverse all of the

components.

Highlight components using the Left Mouse Button in the Graphics Area, and
note how the Global Controls now only affect the highlighted components.

Use the icon ( % ') to switch the global controls between the Geometry,
Elements and Both options.

Review the other Model Browser Views:

< i
a. Component View
This view is highly useful when working solely with components as none of
the other collectors are shown in the view. This view contains all of the
visibility control and right click functions of the Model View. Additionally, it
adds fields that show the mesh and geometry shading as well as the
property and material applied to each component.
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Components ID @ & @ Direct Property Indirect Property PID Property Card Image Thickness Material MID Material Card Image Structural Mass *
ﬂﬂ Support-GEOM-3D 1 [l @ x prop_solid 4 PSOLID Steel 1 MAT1 1.6893461341E-05
@ B cyi3GEOM-1D sA® > v 3.0680675497E-07
@ B piston3GEOM-1D I@® > v 95745033422 07
B cyl2-GEOM-1D sl > v 3.1447329497E-07
@ @ piston2-GEOM-1D OS> v 9.1573980466E 07
ﬂﬂ cyll-GEOM-2D 4 [l @ A v 1.9966113104E-07 =
@ @ piston1-GEOM-1D sO > v 8.7408212112E-07
B supp_cyl_pinGEOM-3D 20 [1] @ & prop_solid_bolt 5 PSOLID Steel 1 MAT1 2.4264196102E-07
ﬂjﬂ supp_pin-GEOM-3D 21 |j| @ A prop_solid_bolt 5 PSOLID Steel 1 MAT1 2.4433738187E-07
ﬂﬂ link1_pin-GEOM-3D 22 [l @ A prop_solid_bolt 5 PSOLID Steel 1 MAT1 1.3171725661E-07
ﬂﬂ pin3-GEOM-3D 23 [. @ A prop_solid_bolt 5 PSOLID Steel 1 MAT1 9.4865939921E-08
ﬂjﬂ pin1-GEOM-3D 24 D @ A prop_solid_bolt 5 PSOLID Steel 1 MAT1 1.0430414279€-07
@ B top_pGEOM-3D e prop_solid_bolt 5  PSOLID Steel 1 MAT1 1.3851927121E-07
=
b. &2 Property View

This view allows the user to view all of the properties in the model and
the color of the entities on the screen by their assigned property. The
visibility controls as well as all right click extended functionality, work
with this view as well.
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% prop_1D_cylinder 6 [] 0 ¥ 1D PBEAM 2 ISOTROPIC Steel S355J2H
%@ prop_10_piston 7 [ 0 (¥ 1D PBEAM 2 ISOTROPIC Steel S355J2H
% prop_t0100 2 0 ¥ 20 PSHELL 1.0 1 ISOTROPIC Steel

&g prop_t0050 10 0 ¥ 2D PSHELL 05 1 ISOTROPIC Steel
%@ prop_solid 4 @ 0 ¥ 30 PSOLID 1 ISOTROPIC Steel
%e prop_solid bolt 5[] 0 ¥ 30 PSOLD 1 ISOTROPIC Steel
s prop_t0170 30 0 ¥ 20 PSHELL 1.7 1 ISOTROPIC Steel

e N
c. LE|Mmaterial View

This view allows the user to view all of the materials in the model and
the color of the entities on the screen by their assigned material. The
visibility controls as well as all right click extended functionality, work

with this view as well.
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& Steel 5355J2H 2 [ 0 [V ISOTROPIC MAT
: [T Steel 13 0 [V ISOTROPIC MAT
[ mat8 30 0 [¥| ORTHOTROPIC MATS

10. Context-Sensitive Menu - You can change a variety of options by right-clicking
on a folder or entity in the browser's tree display. Options you specify in empty
space around the model apply to the entire model.

11.Right click on the Component folder will open the following context menu.
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Try the following functions:

a. Create a new component:

‘@ Cards (1)
[} g Components (25]

; ﬂjﬂ Supporl
L ﬂﬂ cyl3-GE  Assign
B piston3] g

b. Rename a component:

Click Right Mouse Button on component1 and select Rename or Left
Click on the new component “component1” will open below the Entity
Editor tab area, where you can change component name in the Value

field.
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c. Change and choose the component color by clicking the Color Value

field.
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Show/Hide & Isolate a component:

o) [ fink2-GEOM-2D < | 0
‘ B NEW-PART 214 n
E)- 4 Load Collectors (4) D Biely
(1-Igh Load Steps (3) Rerrame 7z
— - Assign
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O EECE—
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Isolate Only a component (see if you can figure out the difference
between Isolate and Isolate Only).

Delete a component:

[ B link2-GEOM-2D kR | 0
@ @ NEW-PART 3I[] o
o Load Collectors (4) Duplicate Ctl+D
‘g Load Steps (3) Fename F2
‘[ Materials (3) Assign
o Properties (7) Card Edit
@ Sets(3) -
2 Titles (1) XRef Entities
B3 Views (3) Review
Name Value Hide
Name NEW-PART Isolate
D N |solate Only
Color O Show
Include File [Master Model] Bt
Property <Unspecified> Collapse
Material <Unspecified>
Delete Advanced k
Empty
Configure Browser
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Step 4: Working with Collectors

1.

Right click on the Model tab > Model View > Component folder will open the

following context menu, select Create.
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The new collector has been created and now we will move the elements for

the bucket into this new collector.

-

select the icon
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2. Left Click on the new component “component1” will open below the Entity
Editor tab area, where you can change component name in the Value field.

In the Entity Editor, name it “Bucket” and select a color.

4. From the menu bar select Mesh > Organize > Elements > To Component or
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Create > . q"’z (=S fO 2 &
Edit L = e o

X ook g
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Delete 4
Card Edit 4
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5. In the Model Browser click the Selector Icon [k This allows you to pick
components from the graphics window.

6. Click the bucket in the graphics window (component “Schaufel-GEOM-2D”).

>
7. Click the Add To Panel Collector icon . This will add the selected

elements, included in “Schaufel-GEOM-2D” component, to the selection.

8. Click the dest component= button and select the newly created “Bucket”
component.

9. Click move and the elements in the collector will be moved to the new
component.

Step 5: Use of Panels and Directional Functions

This step will introduce the user to commonly used functions in panels as well
as the use of the directional definition tools found in many HyperMesh panels.

1. Locate the item in the menu bar that allows you to Translate Elements (Mesh
> Translate > Elements).

A elems I v (D e 14| translate +
translate -
reject
¢ global system | s | magnitude = | 0.000

2. Select the elements included in the component “Support-GEOM-3D”.
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| elms |1

by window
displayed
all
reverse
by collector N

. Keep direction option N1, N2, N3.

[ dems | N N2 ]
$ I global system | s | magnitude = | 0.000

If you want to change the direction options, you have to click E‘ and select
the direction:

- NG 14 |

X-axis N1, N2, N3
y-axis screen normal hitude = |
z-axis creen parallel

vector

X, y and z axis will translate along those cardinal axis, while N1,N2,N3 allows
the user to define a direction as a vector (N1->N2) or as a normal to a plane
defined by the points N1,N2 and N3 following the right hand rule.

. Pick a node on the flat face of the “Support-GEOM-3D” component shown
below. A green dot will appear at the selected node showing that N1 has been
defined there. The blue focus square will automatically move to N2.

. Continue in a Clockwise direction picking two more nodes on the face defining
the blue N2 and red N3 nodes. Your model should look like similar to the
picture above.

NOTE: It is not necessary that your nodes be identical to the image, just
similar.

6. Enter 30 in the magnitude= field.

7. Click translate -.
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The entire component will move 30 model units in the negative direction
defined by the normal of the plane N1, N2 and N3.

8. Click reject.

9. Try moving the component in other directions using both cardinal axis and the
N1, N2 and N3 options.

10.Try moving the component using only N1 and N2 and then change the
magnitude= field to N2-N1 and see what that option works.

11.Use the reject button and the opposite direction translation to bring your
component back to the previous location.

Step 6: Using the Mask Function and Selecting Entities

1. Using the Mask Icon from the Display toolbar to enter the Mask panel.
& mask L‘ elems m

© unmask

2. Change the entity selection to elems.

3. Pick a number of elements on the screen.

4. Click mask.
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This will hide the elements from view but they still can be affected through

other panels.

#

5. Click the Reverse Icon

This will Unmask the hidden elements and will mask all the elements

previously shown.

6. Click the Unmask Adjacent Icon

f |

This will unmask elements immediately adjacent to those on the screen. This

can be done repeatedly.

7. Click the Unmask All Icon ﬂ

8. Click the Mask Icon again.

to bring everything into view.
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9. Hold the Shift Key down and holding the Left Mouse Button, drag a box in the

graphics window to box select elements.

10.Hold the Shift Key down and holding the Right Mouse Button, drag a box in
the graphics window to de-select elements.

11.Click the yellow elems button to open the extended selection window.

by window on plane by geoms by domains
displayed retrieve by group by adjacent
all save duplicate by attached by include
reverse by id by config by face by block
by collector by assems by sets by outputblock by ply

12. Experiment with options, including the following:

displayed — Selects entities currently displayed on the screen
all — Selects ALL entities in the model, displayed or not.

reverse — After selecting a few elements this will “reverse” the
selection.

by collector — Displays a list of collectors and entities can be selected
by the collector they are in.

by geoms — By choosing either surfs or solids, elements can be
selected by picking the geometry that they were created from. Useful
in that a single geometry selection can select many elements.

save/retrieve — Saving a selection places those entities into a 1 slot
“‘user mark” that can be retrieved again and again in selections until it is
overwritten.
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